37. CPU-Leistungsbedarf und Strategien bei der Audiobearbeitung
Audiobearbeitung in Echtzeit kann eine anspruchsvolle Aufgabe für Allzweck-Computer sein, die eher für Tabellenkalkulationen und zum Surfen im Internet konzipiert wurden. Eine Software wie Live benötigt eine leistungsfähige CPU und eine schnelle SSD. Dieses Kapitel bietet einen Einblick, wie sich Probleme mit Computerressourcen bei der Verwendung von Live vermeiden und lösen lassen.
37.1 Die CPU-Last-Anzeige
Um einen kontinuierlichen Audiodatenstrom an die Audio-Hardware leiten zu können, muss Live eine hohe Anzahl von Berechnungen pro Sekunde ausführen. Wenn der Prozessor die erforderlichen Berechnungen nicht schnell genug ausführen kann, wird das Audiosignal Lücken oder Störgeräusche enthalten.
Zu den Faktoren, die die Rechenleistung eines Computers beeinflussen, gehören die Prozessor-Taktrate (in MHz oder GHz), seine Architektur, die Temperatur (in sehr warmen Umgebungen drosseln moderne CPUs ihre Geschwindigkeit), die Leistungsfähigkeit seines Speicher-Cachings (wie effizient der Prozessor auf Daten aus dem Arbeitsspeicher zugreifen kann) und die Bandbreite des System-Busses – der “Pipeline” des Rechners, durch die alle Daten hindurch müssen.
Glücklicherweise unterstützt Live Multicore- und Multiprozessor-Systeme und erlaubt es deshalb, die Rechenlast von Instrumenten, Effekten und I/O optimal auf die verfügbaren Ressourcen zu verteilen. In Abhängigkeit vom Rechner und dem Live Set, kann die zur Verfügung stehende Rechenleistung dadurch ein Vielfaches von der auf älteren Systemen betragen.
37.1.1 Die CPU-Last-Anzeige
Die CPU-Anzeige im Transportbereich gibt Auskunft darüber, wieviel von der Rechenkapazität des Computers momentan genutzt wird. Liegt der angezeigte Prozentsatz beispielsweise bei 10 Prozent, arbeitet der Rechner gewissermaßen noch mit Standgas. Beträgt die Prozentzahl 100, ist die Kapazität am Limit – mit hoher Wahrscheinlichkeit treten Aussetzer, Knackser oder andere Audio-Probleme auf.
Beachten Sie, dass die Last-Anzeige nur die Audioberechnung und sonst keine Prozesse berücksichtigt, die der Rechner abarbeiten muss (zum Beispiel die Benutzeroberfläche von Live).

Die CPU-Anzeige gibt die durchschnittliche und die aktuelle CPU-Last wieder und lässt sich wahlweise ganz ausschalten.
Die CPU-Anzeige zeigt den Anteil der aktuellen Audiobearbeitung an der CPU-Auslastung in Prozent an und nicht die gesamte CPU-Last. Die CPU-Anzeige Aktuell gibt die gegenwärtige CPU-Last insgesamt an.
Ein Klick auf die CPU-Anzeige macht die verschiedenen Optionen sichtbar.

Standardmäßig zeigt Live nicht die aktuelle Last an. Dies muss bewusst über den entsprechenden Eintrag im Auswahl-Menü gemacht werden.
Bei Neuinstallationen von Live 11 ist die CPU-Überlastungsanzeige von vornherein ausgeschaltet. Sie lässt sich im Drop-Down-Menü reaktivieren, wenn die Option Bei CPU-Überlastung warnen ausgewählt ist.
Zum Ermitteln der CPU-Auslastung berechnet Live die Zeit, die benötigt wird, um einen Audio-Buffer zu verarbeiten. Dieser Wert wird dann mit der Zeit verglichen, die zum tatsächlichen Abspielen eines Audio-Buffers benötigt wird.
Ein Wert von 50 % auf der CPU-Anzeige bedeutet beispielsweise, dass Live einen Audio-Buffer doppelt so schnell verarbeitet, wie zum Abspielen des Buffers erforderlich ist.
Werte über 100 % sind möglich, wenn die Signalverarbeitung mehr Zeit in Anspruch nimmt als das Abspielen des Audio-Buffers.
Audioberechnungen haben die höchste Priorität in Live. Deshalb sollte auch bei einer hohen Prozessorlast die Audioausgabe ohne Unterbrechungen und Störungen erfolgen. Aus diesem Grund können andere Anwendungen CPU-Spitzen in der CPU-Anzeige von Live verursachen.
37.1.2 CPU-Last durch Mehrkanal-Audio
Eine Ursache für eine gewisse permanente CPU-Last ist der Transport von Audiodaten zur und von der Audio-Hardware. Diese Last kann minimiert werden, indem man alle in einem Projekt nicht benötigten Ein- und Ausgänge deaktiviert. In den Einstellungen unter Audio befinden sich zwei Schaltflächen für die Dialoge zur Eingangs- und Ausgangskonfiguration, wo sich die einzelnen Ein- und Ausgänge von Mehrkanal-Audio-Hardware (de-)aktivieren lassen.
Live schaltet nicht benötigte Kanäle nicht automatisch ab, da die Audio-Hardware-Treiber einen solchen Wechsel in der Audio-Konfiguration üblicherweise mit hörbaren Aussetzern quittieren.
37.1.3 CPU-Last von Spuren und Geräten
Jede Spur und jedes Gerät, der/das in Live benutzt wird, erhöht generell die CPU-Last etwas. Live ist allerdings "schlau" und vermeidet eine Verschwendung von Rechenzeit bei Spuren und Geräten, die gerade nichts Sinnvolles zum Geschehen beitragen.
Das Einfügen von Geräten in ein Live Set das nicht läuft, erzeugt beispielsweise keinen signifikanten Anstieg der CPU-Last. Die Last steigt erst dann, wenn Sie die Wiedergabe von Clips starten oder Audiosignale in den Effekt leiten. Ohne ein Eingangssignal werden die Effekte deaktiviert, bis wieder ein Signal anliegt. Erzeugt der Effekt einen Nachklang, wie beispielsweise Hall oder Delay, dann wird er erst deaktiviert, wenn alle Berechnungen abgeschlossen sind.
Während dieses Verfahren die durchschnittliche CPU-Last bei Live Sets effektiv reduziert, kann es die Spitzenlast nicht vermindern. Um sicherzugehen, dass ein Live Set auch unter den denkbar schlechtesten Umständen ohne Probleme abgespielt werden kann, sollten Sie testhalber Clips in allen Spuren gleichzeitig abspielen und alle Geräte aktivieren.
In der Session-Ansicht ist es möglich, die Auswirkung jeder einzelnen Spur auf die CPU-Last zu sehen, indem Sie im Mixer-Bereich auf den Schalter Spur-CPU-Last ein-/ausblenden klicken.

In dieser Performance-Impact-Sektion hat jede Spur eine eigene CPU-Anzeige mit sechs kleinen Rechtecken, die den relativen Anteil der Spur an der gesamten CPU-Last des aktuellen Sets anzeigen. Das Einfrieren von Spuren mit dem größten Anteil oder das Entfernen von Spur-Devices sollte die CPU-Last erheblich reduzieren.

37.1.4 Spur einfrieren
Lives Spur-einfrieren-Befehl kann sehr dabei helfen, mit der durch Geräte und Clip-Einstellungen verursachten CPU-Last zu haushalten. Wenn Sie eine Spur auswählen und den Einfrieren-Befehl ausführen, erzeugt Live eine Audiodatei für jeden Session-Clip der Spur sowie eine für das Arrangement. Danach spielen Clips in der Spur einfach diese "eingefrorenen Dateien" ab, statt immer wieder rechenintensive Geräte und Clip-Einstellungen in Echtzeit zu berechnen. Der Befehl Spur einfrieren ist über Lives Bearbeiten-Menü und im Kontextmenü von Spuren und Clips verfügbar. Hierbei ist zu beachten, dass sich Gruppen-Spuren nicht einfrieren lassen, sondern nur Spuren, die Clips enthalten.
Normalerweise erfolgt das Einfrieren sehr schnell. Enthält jedoch eine Spur beim Einfrieren einen External-Audio-Effekt oder ein External Instrument, also mit Routing zu einem Hardware-Effekt oder -Synthesizer, dann erfolgt das Einfrieren in Echtzeit. Live wird automatisch registrieren, ob ein Einfrieren in Echtzeit nötig ist und Ihnen verschiedene Optionen für dieses Vorgang anbieten. Im Abschnitt über das Rendern in Echtzeit werden alle diese Optionen erläutert.
Nachdem Sie die aufgetretenen Leistungsengpässe beseitigt haben (oder Ihren Rechner gegen einen schnelleren getauscht haben!), können Sie eine eingefrorene Spur jederzeit selektieren, ihn mit dem Spur-auftauen-Befehl aus dem Bearbeiten-Menü auftauen und dann die Clip- und Geräte-Einstellungen wieder ändern. Auf langsameren Rechnern können Sie Prozessor-intensive Spuren einen nach dem anderen zum Bearbeiten auftauen und nach getaner Arbeit wieder einfrieren.
Viele Bearbeitungsfunktionen sind auch bei eingefrorenen Spuren verfügbar. Clips zu starten ist weiterhin möglich, und auch Mixer-Parameter wie Lautstärke, Pan und Sends stehen zur Verfügung. Zu den weiteren Möglichkeiten zählen:
- Editieren, Ausschneiden, Kopieren, Einfügen, Duplizieren und Stutzen von Clips.
- Zeichnen und Bearbeiten von Mixer-Automationen und Clip-Hüllkurven.
- Clips konsolidieren.
- Aufzeichnen des Starts von Session-Clips in der Arrangement-Ansicht.
- Erzeugen, Bewegen und Duplizieren von Szenen in der Session-Ansicht.
- das Ziehen von eingefrorenen MIDI-Clips in Audio-Spuren.
Wenn Sie gefrorene Spuren bearbeiten, die zeitbasierte Effekte wie Hall enthalten, sollten Sie beachten, dass das hörbare Resultat je nach Situation unterschiedlich sein kann, wenn die Spur wieder aufgetaut wird. Das ist deswegen so, da die verwendeten Effekte bei gefrorenen Spuren überhaupt nicht berechnet werden und darum auch nicht auf Änderungen am Eingangsmaterial reagieren können. Wenn die Spur wieder aufgetaut wird, werden auch alle Effekte neu in Echtzeit berechnet.

Eingefrorene Spuren in der Arrangement-Ansicht werden auch über die Grenzen ihrer Clips hinaus jedes relevante Material wiedergeben (zum Beispiel die "Fahnen" von Halleffekten). Solche eingefrorenen Fahnen erscheinen im Arrangement als schraffierte Regionen neben ihren zugehörigen Clips. Sie werden von Live als separate, "temporäre" Clips behandelt, die beim Auftauen wieder verschwinden, da dann der Effekt in Echtzeit berechnet wird. Sie werden darum beim Bewegen eines gefrorenen Clips im Arrangement üblicherweise auch den zweiten gefrorenen Fahnen-Clip selektieren und mitbewegen wollen, damit die beiden Clips zusammenbleiben.
Bei eingefrorenen Session-Clips werden nur zwei Loop-Zyklen im Clip eingefroren, was bedeutet, dass Clips mit entkoppelten Clip-Hüllkurven nach zwei Loop-Zyklen im eingefrorenen Zustand anders klingen können als im Original.
Das Ziehen eine eingefrorenen Clips in den Drop-Bereich der Session oder Arrangement-Ansicht erzeugt eine neue eingefrorene Spur, die den Clip enthält. Ist ein Clip teilweise im Arrangement selektiert, enthält die neue erzeugte eingefrorene Spur nur den ausgewählten Teil des Clips.
Die mit dem Befehl Spur einfrieren erzeugten Samples werden im aktuellen Projekt-Ordner unter /Samples/Processed/Freeze gespeichert. Wurde das Set noch nicht gespeichert, wird der Speicherort durch den Temporären Ordner bestimmt. Durch das Sichern werden sie zum Unterordner Ihres Projekt-Ordners bewegt: Samples/Processed/Freeze Bitte beachten Sie, dass "eingefrorene" Samples von solchen Spuren, die ein External Instrument oder einen External Audio Effect enthalten, beim Auftauen dieser Spuren sofort gelöscht werden.
Neben der Möglichkeit, bei Spuren mit zahlreichen Geräten CPU-Ressourcen zu sparen, vereinfacht der Spur-Einfrieren-Befehl den Austausch von Projekten zwischen Rechnern erheblich. Auch langsamere Rechner können große Live Sets abspielen, solange CPU-intensive Spuren darin eingefroren sind. Das Einfrieren ermöglicht auch, dass Rechner, auf denen manche der in einem Live Set verwendeten Geräte nicht verfügbar sind, das Live Set trotzdem abspielen können, solange die Tracks mit den betreffenden Geräten darin eingefroren sind.
37.2 Probleme mit der Festplattengeschwindigkeit
Die Lese-/Schreibgeschwindigkeit einer SSD kann sich auf die Leistung von Live auswirken. Wie viel Datenverkehr Live erzeugt, verhält sich etwa proportional zur Anzahl der verwendeten Audiokanäle, die gleichzeitig gelesen oder geschrieben werden. Eine Spur mit einem Stereo-Sample verursacht dabei mehr Datenverkehr als eine mit einem Mono-Sample.

Die Festplatten-Überlastungsanzeige blinkt auf, wenn die Festplatte die benötigten Daten nicht schnell genug lesen oder schreiben kann. Bei der Audio-Aufnahme macht sich eine Überlastung der Festplatte in Form kleiner Lücken im aufgenommenen Signal bemerkbar; bei der Wiedergabe sind Aussetzer zu hören.
Um eine Überlastung der Festplatte zu vermeiden, können Sie:
- die Anzahl aufgenommener Kanäle reduzieren, durch Anwahl von Mono- statt Stereoeingängen im Kanal-Konfigurations-Dialog in den Einstellungen unter Audio.
- den RAM-Modus für bestimmte Clips verwenden.
- die Anzahl abgespielter Kanäle reduzieren, indem Sie überall wo es möglich ist, Mono- statt Stereo-Samples verwenden. Stereo-Samples lassen sich mithilfe eines beliebigen Audio-Editors in mono umwandeln und in Live referenzieren.